meta-quanta: Add meta-f0b machine

Initial introduction of Quanta F0B family equipped with Aspeed 2500 BMC SoC.

Tested: Build Quanta F0B board and load on the target hardware.
Ensure that BMC boots to console.

Change-Id: I572708c3e900e00ce82844471100c8434946eaf6
Signed-off-by: PKLee-Quanta <p.k.lee@quantatw.com>
diff --git a/meta-f0b/recipes-phosphor/ipmi/f0b-ipmi-fru-read-inventory-native.bb b/meta-f0b/recipes-phosphor/ipmi/f0b-ipmi-fru-read-inventory-native.bb
new file mode 100644
index 0000000..89d8610
--- /dev/null
+++ b/meta-f0b/recipes-phosphor/ipmi/f0b-ipmi-fru-read-inventory-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "F0B inventory map for phosphor-ipmi-host"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${QUANTABASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit native
+inherit phosphor-ipmi-host
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-read-inventory"
+
+S = "${WORKDIR}"
+
+do_install() {
+        DEST=${D}${config_datadir}
+        install -d ${DEST}
+        install config.yaml ${DEST}
+}