meta-quanta: gbs: initialize MAC address and enable USB Network

MAC address: initialize MAC address for all network interfaces
USB-Network: enable usb0 link-local address auto configuration

Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: Ifb8f79ec3560c3aeaef06ae38af64c8259e4bbee
diff --git a/meta-gbs/recipes-quanta/network/mac-address_%.bbappend b/meta-gbs/recipes-quanta/network/mac-address_%.bbappend
new file mode 100644
index 0000000..d975fe2
--- /dev/null
+++ b/meta-gbs/recipes-quanta/network/mac-address_%.bbappend
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS_prepend_gbs := "${THISDIR}/${PN}:"
+SRC_URI_append_gbs = " file://config.txt"
+
+FILES_${PN}_append_gbs = " ${datadir}/mac-address/config.txt"
+
+do_install_append_gbs() {
+    install -d ${D}${datadir}/mac-address
+    install -m 0644 -D ${WORKDIR}/config.txt \
+        ${D}${datadir}/mac-address/config.txt
+}