meta-quanta: gbs: add i2cool temperature calibration

Do i2cool temperature calibration by phosphor-virtual-sensor

Also, as the phosphor-virtual-sensor generate the same D-Bus path,
chage the sensor name in hwmon to avoid the duplicate D-Bus path

Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: I334222da51f33256cf921ee0f3965bf2b607c345
diff --git a/meta-gbs/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend b/meta-gbs/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend
new file mode 100644
index 0000000..aadafeb
--- /dev/null
+++ b/meta-gbs/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS_prepend_gbs := "${THISDIR}/${PN}:"
+
+SRC_URI_append_gbs = " file://config-virtual-sensor.json \
+                       file://phosphor-virtual-sensor.service.replace \
+                     "
+
+do_install_append_gbs() {
+    install -d ${D}${datadir}/${PN}
+    install -m 0644 -D ${WORKDIR}/config-virtual-sensor.json \
+        ${D}${datadir}/${PN}/virtual_sensor_config.json
+
+    install -d ${D}${systemd_system_unitdir}
+    install -m 0644 ${WORKDIR}/${PN}.service.replace \
+        ${D}${systemd_system_unitdir}/${PN}.service
+}