meta-quanta: meta-runbmc-nuvoton: rename meta-olympus-nuvoton
For avoid confusing this layer only with RUNBMC module
(https://www.opencompute.org/documents/ocp-runbmc-daughterboard-card-
design-specification-v1-4-1-pdf)
The meta-runbmc-nuvoton will rename meta-olympus-nuvoton.
That means the Quanta Olympus product with RUNBMC module which based on
Nuvoton SoC.
The layer configuration will binding Olympus product hardware design.
Change-Id: I5dd78c173648ea5db8ae69ee18e340bcd6e52b25
Signed-off-by: Samuel Jiang <Samuel.Jiang@quantatw.com>
diff --git a/meta-olympus-nuvoton/recipes-phosphor/fans/phosphor-pid-control_%.bbappend b/meta-olympus-nuvoton/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
new file mode 100644
index 0000000..a61181d
--- /dev/null
+++ b/meta-olympus-nuvoton/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
@@ -0,0 +1,29 @@
+FILESEXTRAPATHS_prepend_olympus-nuvoton := "${THISDIR}/${PN}:"
+
+SRC_URI_append_olympus-nuvoton = " file://config-olympus-nuvoton.json"
+SRC_URI_append_olympus-nuvoton = " file://fan-full-speed.sh"
+SRC_URI_append_olympus-nuvoton = " file://phosphor-pid-control.service"
+SRC_URI_append_olympus-nuvoton = " file://fan-reboot-control.service"
+
+FILES_${PN}_append_olympus-nuvoton = " ${bindir}/fan-full-speed.sh"
+FILES_${PN}_append_olympus-nuvoton = " ${datadir}/swampd/config.json"
+
+RDEPENDS_${PN} += "bash"
+
+SYSTEMD_SERVICE_${PN}_append_olympus-nuvoton = " phosphor-pid-control.service"
+SYSTEMD_SERVICE_${PN}_append_olympus-nuvoton = " fan-reboot-control.service"
+
+do_install_append_olympus-nuvoton() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${WORKDIR}/fan-full-speed.sh ${D}/${bindir}
+
+ install -d ${D}${datadir}/swampd
+ install -m 0644 -D ${WORKDIR}/config-olympus-nuvoton.json \
+ ${D}${datadir}/swampd/config.json
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/phosphor-pid-control.service \
+ ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/fan-reboot-control.service \
+ ${D}${systemd_unitdir}/system
+}