quanta: update gsj machine configuration

Commit GSJ project configurations.
1. Add configuration for u-boot-evn.
2. Update kernel configuration.
3. Add gsj suffix to some properties.

Tested: Build Quanta GSJ image and load on the GSJ BMC module.
Ensure that BMC boots to console successfully.

Change-Id: Id13a5194b430f6e92b786002db6864362587101b
Signed-off-by: Fran Hsu <Fran.Hsu@quantatw.com>
diff --git a/meta-gsj/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend b/meta-gsj/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend
new file mode 100644
index 0000000..c5aea40
--- /dev/null
+++ b/meta-gsj/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS_prepend_gsj := "${THISDIR}/${PN}:"
+
+SRC_URI_append_gsj = " file://fw_env.config"
+
+do_install_append_gsj () {
+	install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+}