meta-quanta: gbs: add YAML paths/whitelist config/watchdog patch

1. set gbs YAML config paths for sensors and FRUs
2. add gbs IPMI whitelist config
3. add pre-timeout interrupt patch for IPMI watchdog commands

Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: Iacd5942fa056810aca5fd765b50fb7da6581fc96
diff --git a/meta-gbs/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-gbs/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
new file mode 100644
index 0000000..a197022
--- /dev/null
+++ b/meta-gbs/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -0,0 +1,18 @@
+DEPENDS_append_gbs = " gbs-yaml-config"
+
+SRC_URI_remove_gbs = "git://github.com/openbmc/phosphor-host-ipmid"
+SRC_URI_prepend_gbs = "git://github.com/quanta-bmc/phosphor-host-ipmid.git"
+
+SRCREV_gbs = "675d587abd8b068aa1816176221237ac6172a0bc"
+
+FILESEXTRAPATHS_prepend_gbs := "${THISDIR}/${PN}:"
+SRC_URI_append_gbs = " file://gbs-ipmid-whitelist.conf \
+                       file://0063-Save-the-pre-timeout-interrupt-in-dbus-property.patch \
+                     "
+
+WHITELIST_CONF_gbs = "${WORKDIR}/gbs-ipmid-whitelist.conf"
+
+EXTRA_OECONF_append_gbs = " --with-journal-sel \
+     SENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/gbs-yaml-config/ipmi-sensors.yaml \
+     FRU_YAML_GEN=${STAGING_DIR_HOST}${datadir}/gbs-yaml-config/ipmi-fru-read.yaml \
+     "