blob: 37e4e44cf4ec2656208132e71b89e241b7512496 [file] [log] [blame]
Hank Lioub1c33ab2019-06-26 14:00:20 +08001SRC_URI = "git://github.com/quanta-bmc/mac-address.git;protocol=git"
2SRCREV = "${AUTOREV}"
3
4LICENSE = "Apache-2.0"
Brad Bishop170929b2019-09-13 13:04:22 -04005LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Hank Lioub1c33ab2019-06-26 14:00:20 +08006
7inherit autotools pkgconfig
8inherit systemd
9
10DEPENDS += "systemd"
11DEPENDS += "autoconf-archive-native"
12
13FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
14SRC_URI_append = " file://mac-address.service"
15
16HASHSTYLE = "gnu"
17S = "${WORKDIR}/git"
18CXXFLAGS += "-std=c++17"
19
20do_install_append() {
21 install -d ${D}${systemd_unitdir}/system/
22 install -m 0644 ${WORKDIR}/mac-address.service \
23 ${D}${systemd_unitdir}/system
24}
25
26SYSTEMD_PACKAGES = "${PN}"
27SYSTEMD_SERVICE_${PN} += "mac-address.service"