quanta-q71l: add phosphor-hwmon configs

This provides configurations for phosphor-hwmon to provide fans and
temperature sensors.  They also need to be in the devicetree, but this
is where they would be if they were.

Change-Id: I33911818d0a315dc156bff28c70ec3e91403f0bb
Signed-off-by: Patrick Venture <venture@google.com>
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/sensors/phosphor-hwmon%.bbappend b/meta-quanta/meta-q71l/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
new file mode 100644
index 0000000..28357d1
--- /dev/null
+++ b/meta-quanta/meta-q71l/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+# More conf files can be added as sensors are added.
+
+ITEMS = "pwm-tacho-controller@1e786000.conf"
+
+TEMPS = "tmp75@4c tmp75@4e tmp75@4f"
+TEMPBASE = "apb/i2c@1e78a000/i2c-bus@80/{0}.conf"
+ITEMS += "${@compose_list(d, 'TEMPBASE', 'TEMPS')}"
+
+ENVS = "obmc/hwmon/ahb/{0}"
+SYSTEMD_ENVIRONMENT_FILE_${PN} += "${@compose_list(d, 'ENVS', 'ITEMS')}"