nicole: u-boot: Add system reset state support
This is a backport of the patch file from intel-bmc/openbmc repository.
It makes the u-boot to add the system reset status to the bootargs.
tested: the /proc/cmdline must contain:
- resetreason=power after cold bmc boot
- resetreason=watchdog after warm bmc reboot
Change-Id: I4a5d2ecbfb631dacc0037a9925225b895c5e9b03
Signed-off-by: Alexander Filippov <a.filippov@yadro.com>
diff --git a/meta-nicole/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend b/meta-nicole/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
new file mode 100644
index 0000000..f0ff09e
--- /dev/null
+++ b/meta-nicole/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_append := "${THISDIR}/files:"
+
+SRC_URI_append = " \
+ file://0001-Add-system-reset-status-support.patch \
+ "