poky: sumo refresh 36d5cee56b..d240b885f2

Update poky to sumo HEAD.

Changqing Li (1):
      libsndfile1: CVE-2018-13139

Chen Qi (2):
      runqemu: add SIGTERM handler to make sure things are cleaned up
      runqemu: fix handling of SIGTERM and the problem of line wrapping

Hongxu Jia (1):
      nasm: fix CVE-2018-10016

Ioan-Adrian Ratiu (1):
      rootfs: always update the opkg index

Jagadeesh Krishnanjanappa (1):
      runqemu: exit gracefully with an error message if qemu system is not evaluated

Joe Slater (1):
      libtiff: fix CVE-2017-17095

Khem Raj (1):
      x264: Disable asm on musl/x86

Nicolas Dechesne (1):
      checklayer: avoid recursive loop in add_layer_dependencies

Ola x Nilsson (1):
      externalsrc.bbclass: Set BB_DONT_CACHE for non-target recipes

Richard Purdie (1):
      recipes: Update git.gnome.org addresses after upstream changes

Sinan Kaya (3):
      libxml2: CVE-2018-14404
      python3: CVE-2018-1061
      git: CVE-2018-11233

Change-Id: Ic2daa2803af197180e605346f59bab03f8264e19
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/poky/meta/classes/externalsrc.bbclass b/poky/meta/classes/externalsrc.bbclass
index c9f5cf7..78a08c8 100644
--- a/poky/meta/classes/externalsrc.bbclass
+++ b/poky/meta/classes/externalsrc.bbclass
@@ -41,8 +41,8 @@
     # re-parsed so that the file-checksums function for do_compile is run every
     # time.
     bpn = d.getVar('BPN')
-    if bpn == d.getVar('PN'):
-        classextend = (d.getVar('BBCLASSEXTEND') or '').split()
+    classextend = (d.getVar('BBCLASSEXTEND') or '').split()
+    if bpn == d.getVar('PN') or not classextend:
         if (externalsrc or
                 ('native' in classextend and
                  d.getVar('EXTERNALSRC_pn-%s-native' % bpn)) or