ipmi: Refactor whitelist generation

The current dual-use of packagegroup-ipmid-providers as a
dependency insertion point for both native (whitelists) and
runtime (provider libs) doesn't work under Yocto 2.3.

Move the ipmi provider configuration from recipe scope to
the global configuration scope so we can continue to avoid
dually maintaining whitelist and provider lists _and_ build
under Yocto 2.3.

Also rename OBMC_IPMID_PROVIDERS with the more conventional
VIRTUAL-RUNTIME_phosphor-ipmi-providers.

Change-Id: I1acce0b08047cba2312f60542942cccbcff66aec
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
index fe32be2..180d70d 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
@@ -12,10 +12,18 @@
 inherit phosphor-ipmi-host
 inherit pythonnative
 
+def ipmi_whitelists(d):
+    whitelists = d.getVar(
+        'VIRTUAL-RUNTIME_phosphor-ipmi-providers', True) or ''
+    whitelists = whitelists.split()
+    whitelists = [ '{}-whitelist-native'.format(x) for x in whitelists ]
+    return ' '.join(whitelists)
+
+
 DEPENDS += "autoconf-archive-native"
 DEPENDS += "nlohmann-json"
 DEPENDS += "obmc-targets"
-DEPENDS += "packagegroup-obmc-ipmid-providers"
+DEPENDS += "${@ipmi_whitelists(d)}"
 DEPENDS += "phosphor-dbus-interfaces"
 DEPENDS += "phosphor-logging"
 DEPENDS += "phosphor-mapper"