meta-quanta: Add meta-f0b machine

Initial introduction of Quanta F0B family equipped with Aspeed 2500 BMC SoC.

Tested: Build Quanta F0B board and load on the target hardware.
Ensure that BMC boots to console.

(From meta-quanta rev: b0d87650a1f20510596881a37c6a4424c6c5781a)

Change-Id: Ieb5aad2f897dc8fb1840e0db2929b9350e3fa063
Signed-off-by: PKLee-Quanta <p.k.lee@quantatw.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-quanta/meta-f0b/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend b/meta-quanta/meta-f0b/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
new file mode 100644
index 0000000..b9d7fb3
--- /dev/null
+++ b/meta-quanta/meta-f0b/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
@@ -0,0 +1,22 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+EXTRA_OECONF_append_f0b = " --enable-negative-errno-on-fail"
+
+NAME = " \
+        i2c@1e78a000/i2c-bus@80/tmp421@4c \
+        i2c@1e78a000/i2c-bus@1c0/tmp421@4c \
+        i2c@1e78a000/i2c-bus@180/tps53679@60\
+        i2c@1e78a000/i2c-bus@180/tps53659@62\
+        i2c@1e78a000/i2c-bus@180/tps53659@64\
+        i2c@1e78a000/i2c-bus@180/tps53679@70\
+        i2c@1e78a000/i2c-bus@180/tps53659@72\
+        i2c@1e78a000/i2c-bus@180/tps53659@74\
+        i2c@1e78a000/i2c-bus@180/ina219@40\
+        i2c@1e78a000/i2c-bus@180/ina219@41\
+        "
+ITEMSFMT = "ahb/apb/{0}.conf"
+
+ITEMS = "${@compose_list(d, 'ITEMSFMT', 'NAME')}"
+
+ENVS = "obmc/hwmon/{0}"
+SYSTEMD_ENVIRONMENT_FILE_${PN} += "${@compose_list(d, 'ENVS', 'ITEMS')}"