Add required package "pkgconfig"

This package is required for the following receipes
in yocto-2.3.
Otherwise we get the error:
"fatal error: gio/gio.h: No such file or directory"

Change-Id: I020c8f31d707da716956b7856ba14076294bd7c7
Signed-off-by: Saqib Khan <khansa@us.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/skeleton/obmc-libobmc-intf.bb b/meta-phosphor/common/recipes-phosphor/skeleton/obmc-libobmc-intf.bb
index 39043c0..09027dd 100644
--- a/meta-phosphor/common/recipes-phosphor/skeleton/obmc-libobmc-intf.bb
+++ b/meta-phosphor/common/recipes-phosphor/skeleton/obmc-libobmc-intf.bb
@@ -4,6 +4,7 @@
 PR = "r1"
 
 inherit skeleton
+inherit pkgconfig
 
 DEPENDS += "glib-2.0"