Clean up stale obmc-phosphor-utils references

There were a number of places that inherited this class but did not
use it.  A number of classes that did use it did not inherit it.
This was possible because the class was pulled in by the distro
configuration but that has been removed here as well.

Tested: Built and verified a witherspoon image
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Change-Id: I73511cdcc609875b4fe016967c1b84c5200fb703
diff --git a/meta-phosphor/classes/obmc-phosphor-ipmiprovider-symlink.bbclass b/meta-phosphor/classes/obmc-phosphor-ipmiprovider-symlink.bbclass
index 02f7ce0..7a86496 100644
--- a/meta-phosphor/classes/obmc-phosphor-ipmiprovider-symlink.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-ipmiprovider-symlink.bbclass
@@ -1,5 +1,7 @@
 # Common code for recipes that create IPMI provider libraries
 
+inherit obmc-phosphor-utils
+
 LIBDIR = "${D}/${libdir}/ipmid-providers/"
 HOSTIPMI_LIBDIR = "${D}/${libdir}/host-ipmid/"
 NETIPMI_LIBDIR = "${D}/${libdir}/net-ipmid/"