meta-ibm/wspoon: Switch fan presence to JSON config

Enable the use of JSON and install the fan presence JSON config file
into the witherspoon image. The other fan applications will continue to
use their respective YAML build time config file(s).

Tested:
    Built witherspoon image, uses JSON config
    Built mihawk image, continues to use YAML

(From meta-ibm rev: a6817ca6ca8c87a10eb325835ba4db59109f6101)

Change-Id: I1b675e8a3b064b04007d7474d12e5d5ad2094dad
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
index 8f2097c..9442477 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
@@ -1 +1,11 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+
+SRC_URI_witherspoon = "file://config.json"
+
+do_install_witherspoon() {
+        install -d ${D}/${datadir}/phosphor-fan-presence/presence/
+        install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/presence/
+}
+
+FILES_${PN}_append_witherspoon = " ${datadir}/phosphor-fan-presence/presence/config.json"
+FILES_${PN}_remove_witherspoon = "${presence_datadir}/config.yaml"