meta-ibm/wspoon: Switch fan presence to JSON config

Enable the use of JSON and install the fan presence JSON config file
into the witherspoon image. The other fan applications will continue to
use their respective YAML build time config file(s).

Tested:
    Built witherspoon image, uses JSON config
    Built mihawk image, continues to use YAML

(From meta-ibm rev: a6817ca6ca8c87a10eb325835ba4db59109f6101)

Change-Id: I1b675e8a3b064b04007d7474d12e5d5ad2094dad
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
index 243a02f..70bbc77 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -50,3 +50,7 @@
 # Link fan control service to also start at poweron
 FMT_CONTROL_PWRON_witherspoon = "../${TMPL_CONTROL}:${POWERON_TGT}.requires/${INSTFMT_CONTROL}"
 SYSTEMD_LINK_${PN}-control_witherspoon += "${@compose_list(d, 'FMT_CONTROL_PWRON', 'OBMC_CHASSIS_INSTANCES')}"
+
+# Enable the use of JSON on the fan applications that support it
+EXTRA_OECONF_append_witherspoon = " --enable-json"
+RDEPENDS_${PN}-presence-tach_append_witherspoon = " phosphor-fan-presence-config"