phosphor-objmgr: recipe cleanups

Big cleanups to the phosphor-mapper/phosphor-objmgr recipe.

  - Remove all "mapper-config-native" constructs as the underlying
    repository has no such support.

  - Remove all mapper-related bbclasses as they are no longer relevant.

  - Remove environment support in service file as the mapper executable
    no longer supports any arguments.

  - Greatly simplify the 'libmapper' packaging to avoid stray python
    in the recipe.

  - Update all recipes to use `DEPENDS += "libmapper"` where appropriate
    for clarity if they use libmapper.

  - Rename the recipe from phosphor-mapper to phosphor-objmgr to match
    the repository name, which allows simpler devtool invocations.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I5a64e2feddd1a7919813e007411f9c28b6c9a330
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
index 3922260..6794a09 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
@@ -41,7 +41,7 @@
 DEPENDS += "${@ipmi_whitelists(d)}"
 DEPENDS += "phosphor-dbus-interfaces"
 DEPENDS += "phosphor-logging"
-DEPENDS += "phosphor-mapper"
+DEPENDS += "libmapper"
 DEPENDS += "sdbusplus"
 DEPENDS += "${PYTHON_PN}-sdbus++-native"
 DEPENDS += "virtual/phosphor-ipmi-inventory-sel"