Create mrw-perl-tools recipe

The mrw-perl-tools recipe makes use of the Build.PL script in
phosphor-mrw-tools to determine which scripts and modules to install.
Build.PL is part of Perl's Module::Build installation method which is
executed by the cpan_build bbclass.

Change-Id: Ic5d51e8ec58b4450eeb27843b11332f556f3c35b
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/mrw/mrw-perl-tools-native.bb b/meta-phosphor/common/recipes-phosphor/mrw/mrw-perl-tools-native.bb
new file mode 100644
index 0000000..f2cc509
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/mrw/mrw-perl-tools-native.bb
@@ -0,0 +1,13 @@
+SUMMARY = "OpenBMC MRW Perl Tools"
+DESCRIPTION = "OpenBMC Perl tools for the machine readable workbook"
+S = "${WORKDIR}/git"
+
+inherit obmc-phosphor-license
+inherit native
+inherit cpan_build
+inherit mrw-rev
+
+DEPENDS += "libmodule-build-perl-native mrw-api-native yaml-tiny"
+
+SRC_URI += "${MRW_TOOLS_SRC_URI}"
+SRCREV = "${MRW_TOOLS_SRCREV}"