Create bbclass for python in autotools recipes

Add the base requirements for building and installing python scripts
within a package using autotools.

Change-Id: Ia6f6a819a80bc346153ff5c53cefad41d973d953
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
diff --git a/meta-phosphor/classes/obmc-phosphor-python-autotools.bbclass b/meta-phosphor/classes/obmc-phosphor-python-autotools.bbclass
new file mode 100644
index 0000000..408d15c
--- /dev/null
+++ b/meta-phosphor/classes/obmc-phosphor-python-autotools.bbclass
@@ -0,0 +1,8 @@
+inherit pythonnative
+
+export BUILD_SYS
+export HOST_SYS
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
+FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"