meta-raspberrypi: subtree update:05c86e3160..6f85d3f665

Bartłomiej Burdukiewicz (1):
      linux-raspberrypi_5.4.bb: Update to latest

Drew Moseley (1):
      raspberrypi3: Switch to vc4-fkms-v3d.

Fabio Berton (1):
      rpi-u-boot-scr: Set u-boot-default-script as provider

Khem Raj (20):
      rpio: Use python3 during build
      gstreamer1.0-plugins-base: Adjust for meson conversion
      mesa: Fix patch fuzz
      linux-raspberrypi: Fix building selftest/bpf
      oeqa: Add rpi specific kernel dmesg parser
      linux-raspberrypi: Get PMU fixes on top of 4.19.108
      qtbase: Append userland to rdeps iff vc4graphics is not enabled
      qtbase: Drop xkb packageconfig
      userland: Update to 20200316 snapshot
      userland: Fix build with gcc10
      rpi-base: Drop old dtbo names
      linux-raspberrypi: Add recipes for kernel 5.4
      linux-raspberrypi_5.4.bb: Update to latest and fix build with binutils 2.34
      linux-raspberrypi_5.4.bb: Enable powersave options in kconfig
      linux-raspberrypi_5.4.bb: Backport the patch to use CHECK macro instead of RET_IF
      linux-raspberrypi_5.4.bb: Update to latest
      linux-firmware-rpidistro: Upgrade to 20190114-1+rpt6
      psplash: Do not define ALTERNATIVE_PRIORITY for non-existing provider
      linux-raspberrypi_5.4.bb: Update to latest
      linux-raspberrypi_5.4.bb: Update to 5.4.35

Leon Anavi (3):
      docs/extra-build-config.md: Auto-load I2C modules
      rpi-base.inc: Add kernel modules to all images
      rpi-base.inc: Include modules if I2C is enaled

Madhavan Krishnan (1):
      gstreamer: Fix the compilation issue in meta multimedia image

Martin Jansa (7):
      userland: add pkg-config for openmaxil and add virtual/libomxil to PROVIDES
      gstreamer1.0-plugins-base: adapt to gstreamer1.0 now using meson
      gstreamer1.0-omx: let virtual/libomxil dependency to pull userland
      omxplayer: respect virtual/libomxil
      packagegroup-rpi-test: include bigbuckbunny in RRECOMMENDS_${PN} only with meta-multimedia
      packagegroup-rpi-test: use MACHINE_ARCH
      linux-raspberrypi: fix perf build with latest binutils

Orne Brocaar (1):
      rpi-base.conf: add disable-bt.dtbo and miniuart-bt.dtbo overlays.

Pierre-Jean Texier (17):
      kas-poky-rpi: add kas file
      rpi-base.inc: use wic.bz2 for all rpi machines by default
      linux-raspberrypi: bump to Linux version 4.19.97
      raspberrypi-firmware: bump to version 20200205
      linux-raspberrypi: bump to Linux version 4.19.102
      linux-raspberrypi: bump to Linux version 4.19.105
      raspberrypi-firmware: update to current HEAD
      linux-raspberrypi: bump to Linux version 4.19.108
      raspberrypi-firmware: update to current HEAD
      layer.conf: add dunfell to compat layer
      raspberrypi-firmware: update to current HEAD
      linux-raspberrypi: bump to Linux version 4.19.113
      README.md: add status badge for raspberrypi4
      raspberrypi-firmware: update to current HEAD
      linux-raspberrypi: bump to Linux version 4.19.115
      raspberrypi-firmware: update to current HEAD
      linux-raspberrypi: bump to Linux version 4.19.120

rkhan467 (1):
      mesa: querying dma_buf modifiers for specific formats

Change-Id: I956a7aedff5028fa3af56b101ecaad17b3ff64e0
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-raspberrypi/classes/sdcard_image-rpi.bbclass b/meta-raspberrypi/classes/sdcard_image-rpi.bbclass
index 177988e..43426b2 100644
--- a/meta-raspberrypi/classes/sdcard_image-rpi.bbclass
+++ b/meta-raspberrypi/classes/sdcard_image-rpi.bbclass
@@ -58,7 +58,7 @@
     rpi-config:do_deploy \
     ${@bb.utils.contains('MACHINE_FEATURES', 'armstub', 'armstubs:do_deploy', '' ,d)} \
     ${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'u-boot:do_deploy', '',d)} \
-    ${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'rpi-u-boot-scr:do_deploy', '',d)} \
+    ${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'u-boot-default-script:do_deploy', '',d)} \
 "
 
 do_image_rpi_sdimg[recrdeps] = "do_build"