meta-raspberrypi: subtree update:05c86e3160..6f85d3f665

Bartłomiej Burdukiewicz (1):
      linux-raspberrypi_5.4.bb: Update to latest

Drew Moseley (1):
      raspberrypi3: Switch to vc4-fkms-v3d.

Fabio Berton (1):
      rpi-u-boot-scr: Set u-boot-default-script as provider

Khem Raj (20):
      rpio: Use python3 during build
      gstreamer1.0-plugins-base: Adjust for meson conversion
      mesa: Fix patch fuzz
      linux-raspberrypi: Fix building selftest/bpf
      oeqa: Add rpi specific kernel dmesg parser
      linux-raspberrypi: Get PMU fixes on top of 4.19.108
      qtbase: Append userland to rdeps iff vc4graphics is not enabled
      qtbase: Drop xkb packageconfig
      userland: Update to 20200316 snapshot
      userland: Fix build with gcc10
      rpi-base: Drop old dtbo names
      linux-raspberrypi: Add recipes for kernel 5.4
      linux-raspberrypi_5.4.bb: Update to latest and fix build with binutils 2.34
      linux-raspberrypi_5.4.bb: Enable powersave options in kconfig
      linux-raspberrypi_5.4.bb: Backport the patch to use CHECK macro instead of RET_IF
      linux-raspberrypi_5.4.bb: Update to latest
      linux-firmware-rpidistro: Upgrade to 20190114-1+rpt6
      psplash: Do not define ALTERNATIVE_PRIORITY for non-existing provider
      linux-raspberrypi_5.4.bb: Update to latest
      linux-raspberrypi_5.4.bb: Update to 5.4.35

Leon Anavi (3):
      docs/extra-build-config.md: Auto-load I2C modules
      rpi-base.inc: Add kernel modules to all images
      rpi-base.inc: Include modules if I2C is enaled

Madhavan Krishnan (1):
      gstreamer: Fix the compilation issue in meta multimedia image

Martin Jansa (7):
      userland: add pkg-config for openmaxil and add virtual/libomxil to PROVIDES
      gstreamer1.0-plugins-base: adapt to gstreamer1.0 now using meson
      gstreamer1.0-omx: let virtual/libomxil dependency to pull userland
      omxplayer: respect virtual/libomxil
      packagegroup-rpi-test: include bigbuckbunny in RRECOMMENDS_${PN} only with meta-multimedia
      packagegroup-rpi-test: use MACHINE_ARCH
      linux-raspberrypi: fix perf build with latest binutils

Orne Brocaar (1):
      rpi-base.conf: add disable-bt.dtbo and miniuart-bt.dtbo overlays.

Pierre-Jean Texier (17):
      kas-poky-rpi: add kas file
      rpi-base.inc: use wic.bz2 for all rpi machines by default
      linux-raspberrypi: bump to Linux version 4.19.97
      raspberrypi-firmware: bump to version 20200205
      linux-raspberrypi: bump to Linux version 4.19.102
      linux-raspberrypi: bump to Linux version 4.19.105
      raspberrypi-firmware: update to current HEAD
      linux-raspberrypi: bump to Linux version 4.19.108
      raspberrypi-firmware: update to current HEAD
      layer.conf: add dunfell to compat layer
      raspberrypi-firmware: update to current HEAD
      linux-raspberrypi: bump to Linux version 4.19.113
      README.md: add status badge for raspberrypi4
      raspberrypi-firmware: update to current HEAD
      linux-raspberrypi: bump to Linux version 4.19.115
      raspberrypi-firmware: update to current HEAD
      linux-raspberrypi: bump to Linux version 4.19.120

rkhan467 (1):
      mesa: querying dma_buf modifiers for specific formats

Change-Id: I956a7aedff5028fa3af56b101ecaad17b3ff64e0
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-raspberrypi/recipes-graphics/userland/userland_git.bb b/meta-raspberrypi/recipes-graphics/userland/userland_git.bb
index 99a3f23..eefc1ec 100644
--- a/meta-raspberrypi/recipes-graphics/userland/userland_git.bb
+++ b/meta-raspberrypi/recipes-graphics/userland/userland_git.bb
@@ -6,17 +6,18 @@
 LIC_FILES_CHKSUM = "file://LICENCE;md5=0448d6488ef8cc380632b1569ee6d196"
 
 PROVIDES += "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "", "virtual/libgles2 virtual/egl", d)}"
+PROVIDES += "virtual/libomxil"
 
 RPROVIDES_${PN} += "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "", "libgles2 egl libegl libegl1 libglesv2-2", d)}"
 COMPATIBLE_MACHINE = "^rpi$"
 
 SRCBRANCH = "master"
 SRCFORK = "raspberrypi"
-SRCREV = "17d2fdc1abd370e09ba7074753294c7976dd6b0d"
+SRCREV = "6fb59736b1ae80fc62cddfe3309c800f72e1c07e"
 
 # Use the date of the above commit as the package version. Update this when
 # SRCREV is changed.
-PV = "20190724"
+PV = "20200316"
 
 SRC_URI = "\
     git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \
@@ -39,6 +40,8 @@
     file://0017-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch \
     file://0018-Add-EGL_IMG_context_priority-related-defines.patch \
     file://0019-libfdt-Undefine-__wordsize-if-already-defined.patch \
+    file://0020-openmaxil-add-pkg-config-file.patch \
+    file://0021-cmake-Disable-format-overflow-warning-as-error.patch \
 "
 S = "${WORKDIR}/git"
 
@@ -73,6 +76,10 @@
 		rm -rf ${D}${libdir}/pkgconfig/egl.pc ${D}${libdir}/pkgconfig/glesv2.pc \
 			${D}${libdir}/pkgconfig/wayland-egl.pc
 		rm -rf ${D}${includedir}/EGL ${D}${includedir}/GLES* ${D}${includedir}/KHR
+        else
+                ln -sf brcmglesv2.pc ${D}${libdir}/pkgconfig/glesv2.pc
+                ln -sf brcmegl.pc ${D}${libdir}/pkgconfig/egl.pc
+                ln -sf brcmvg.pc ${D}${libdir}/pkgconfig/vg.pc
 	fi
 }