Add hostlogger support

Added hostlogger support to store console
histories for all the host.

TESTED : Built the openbmc image targetting
Facebook Tiogapass and YosemiteV2 hardware.
Verified all the host log were generated.

Signed-off-by: Kumar Thangavel <thangavel.k@hcl.com>
Change-Id: Iee494d8ce025a253f0e7f915ec893acc44fd84a1
diff --git a/meta-facebook/recipes-phosphor/hostlogger/phosphor-hostlogger_%.bbappend b/meta-facebook/recipes-phosphor/hostlogger/phosphor-hostlogger_%.bbappend
new file mode 100644
index 0000000..3c280ce
--- /dev/null
+++ b/meta-facebook/recipes-phosphor/hostlogger/phosphor-hostlogger_%.bbappend
@@ -0,0 +1,17 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://ttyS2.conf"
+
+SRC_URI_append_yosemitev2 += "file://ttyS0.conf"
+SRC_URI_append_yosemitev2 += "file://ttyS1.conf"
+SRC_URI_append_yosemitev2 += "file://ttyS3.conf"
+
+do_install_append() {
+
+          # Install the configurations
+          install -m 0755 -d ${D}${sysconfdir}/${BPN}
+          install -m 0644 ${WORKDIR}/*.conf ${D}${sysconfdir}/${BPN}/
+
+          # Remove upstream-provided default configuration
+          rm -f ${D}${sysconfdir}/${BPN}/ttyVUART0.conf
+}