meta-phosphor: obmc-console: Convert recipe to meson

Upstream obmc-console now supports the meson build system. I consider
the autotools build system deprecated and intend to remove it.

Change-Id: Ic8eea195bee0b3bea1cb9418593596ce1aaceeae
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
diff --git a/meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend b/meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend
index 0253c39..c6eb07c 100644
--- a/meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend
@@ -35,7 +35,7 @@
 SYSTEMD_SERVICE:${PN}:remove:fb-compute-multihost = "obmc-console-ssh.socket"
 SYSTEMD_SERVICE:${PN}:remove:fb-compute-multihost = "obmc-console-ssh@.service"
 
-EXTRA_OECONF:append:fb-compute-multihost = " --enable-concurrent-servers"
+PACKAGECONFIG:append:fb-compute-multihost = " concurrent-servers"
 
 do_install:append() {
         # Install the server configuration