meta-phosphor: obmc-console: Convert recipe to meson

Upstream obmc-console now supports the meson build system. I consider
the autotools build system deprecated and intend to remove it.

Change-Id: Ic8eea195bee0b3bea1cb9418593596ce1aaceeae
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
diff --git a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
index 742fcef..719ce96 100644
--- a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
+++ b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
@@ -7,11 +7,9 @@
             systemd \
            "
 SRCREV = "86e3fd70f003264a05a09452c60ea8b9da6be287"
-PACKAGECONFIG ??= "udev ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
-PACKAGECONFIG[udev] = "--with-udevdir=`pkg-config --variable=udevdir udev`,\
-                       --without-udevdir,udev"
-PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}, \
-                          --without-systemdsystemunitdir"
+PACKAGECONFIG ??= "udev"
+PACKAGECONFIG[udev] = "-Dudev=enabled,-Dudev=disabled,udev"
+PACKAGECONFIG[concurrent-servers] = "-Dconcurrent-servers=true,-Dconcurrent-servers=false,"
 PV = "1.0+git${SRCPV}"
 PR = "r1"
 
@@ -25,7 +23,7 @@
                 obmc-console@.service \
                 "
 
-inherit autotools pkgconfig
+inherit meson pkgconfig
 inherit obmc-phosphor-discovery-service
 inherit systemd