meta-nuvoton: upgrade npcm8xx-igps recipe

Upgrade IGPS from 03.06.02 to 03.06.04 and remove duplicate deploy

Previous npcm8xx-ipgs recipe will deploy BB and TIPFW binary.
However, BB and TIPFW recipes already were merged recently.
They will do their own deploy task individually.
Thus, we should remove duplicate deploy in igps recipe.

IGPS 03.06.04 - Aug 14 2022
==============
- TIP_FW 0.4.1 L0 0.2.6 L1
   * flash driver bug fixes.
   * Core reset bug fix: CORSTC: set to 1s, except MC bit
   * Do not continue if BMC fail to boot.
   * RESSR: copy values from TIP_SCR1 to INTCR2. Print last reset type.
   * OEM: read 2 bytes from OTP (was 1).
- Bootblock is alligned to 512KB.

Signed-off-by: Tim Lee <timlee660101@gmail.com>
Change-Id: Id0b7336f0b2ada9e43385d635f3e3536a70aad8d
diff --git a/meta-nuvoton/recipes-bsp/images/npcm8xx-igps-native_03.06.04.bb b/meta-nuvoton/recipes-bsp/images/npcm8xx-igps-native_03.06.04.bb
new file mode 100644
index 0000000..498275e
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/images/npcm8xx-igps-native_03.06.04.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Image Generation and Programming Scripts for NPCM8XX (Arbel) devices"
+DESCRIPTION = "Image Generation and Programming Scripts for NPCM8XX (Arbel) devices"
+HOMEPAGE = "https://github.com/Nuvoton-Israel/igps-npcm8xx"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = " \
+    git://github.com/Nuvoton-Israel/igps-npcm8xx;branch=main;protocol=https \
+    file://0001-Adjust-paths-for-use-with-Bitbake.patch \
+"
+
+# tag IGPS_03.06.04
+SRCREV = "6b056bb97a8f0e677d196afb6704372cae8bdd5b"
+
+S = "${WORKDIR}/git"
+
+DEST = "${D}${datadir}/${BPN}"
+
+do_install() {
+	install -d ${DEST}
+	install py_scripts/ImageGeneration/references/BootBlockAndHeader_${DEVICE_GEN}_${IGPS_MACHINE}.xml ${DEST}
+	install py_scripts/ImageGeneration/references/UbootHeader_${DEVICE_GEN}.xml ${DEST}
+	install py_scripts/ImageGeneration/inputs/BL31_AndHeader.xml ${DEST}
+	install py_scripts/ImageGeneration/inputs/OpTeeAndHeader.xml ${DEST}
+}
+
+inherit native