logging: refactor virtualized recipe build deps

React to a bitbake behavioral change when removing build
dependencies from virtualized recipes.  Starting with Yocto 2.3 the
recipe dependencies indicated in the patch are not removed from
the dependency list.

Minor whitespace change.

Dropped nativesdk-phosphor-logging dependency removal as it wasn't
a base dependency in the first place.

Tested: Built the recipe in all effected recipe contexts
Change-Id: I07b40951fff752af44dcdc32f5a301e3912bbdc3
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging.bb b/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging.bb
index b64e34e..dd050f0 100644
--- a/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging.bb
+++ b/meta-phosphor/common/recipes-phosphor/logging/phosphor-logging.bb
@@ -40,11 +40,11 @@
 
 # Do not DEPEND on the specified packages for native build
 # as they will not be available in host machine
-DEPENDS_remove_class-native =   " \
+DEPENDS_remove_class-native = " \
         virtual/phosphor-logging-callouts \
-        sdbus++-native \
-        systemd-native \
-        cereal-native \
+        sdbus++ \
+        systemd \
+        cereal \
         "
 
 # Do not DEPEND on the specified packages for native SDK build
@@ -52,10 +52,9 @@
 DEPENDS_remove_class-nativesdk = " \
         virtual/phosphor-logging-callouts \
         sdbus++-native \
-        nativesdk-cereal \
-        nativesdk-systemd \
-        nativesdk-phosphor-dbus-interfaces \
-        nativesdk-phosphor-logging \
+        cereal \
+        systemd \
+        phosphor-dbus-interfaces \
         "
 
 PACKAGECONFIG ??= "metadata-processing install_scripts"