initramfs: Add init script for eMMC
This init script mounts the rootfs based on the root u-boot env
variable, mounts the read-write filesystem and sets up the overlay.
(From meta-phosphor rev: 86164b2e072cc6cebc9caf1614e2b1fa0e0884a0)
Change-Id: If9121048b6223d5391e5f6a8b7d6cd7d22707969
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb
index 739aab5..4c7237f 100644
--- a/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb
+++ b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb
@@ -2,7 +2,11 @@
the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
first 'init' program more efficiently."
-PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} obmc-phosphor-initfs"
+# Init scripts
+INIT_PACKAGE = "obmc-phosphor-initfs"
+INIT_PACKAGE_df-phosphor-mmc = "phosphor-mmc-init"
+
+PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} ${INIT_PACKAGE}"
# Do not pollute the initrd image with rootfs features
IMAGE_FEATURES = "read-only-rootfs"