Providing infra for FRUs which are accessible through host but host is
not sending the details for those FRUs

- This commit adds a hand written YAML file that specifies IPMI FRU
information. It is for special case where FRU info is not coming as a
write-fru, it coming as a write-sensor from host because host doesn't
have the required i2c access to read the GPU FRU data.
- The YAML in this commit is mostly empty, and system specific overrides
are supposed to add appropriate content.

Partially Resolves openbmc/openbmc#3039

Change-Id: I20b43d1bb4c472dc590d254b72340fb19c52b811
Signed-off-by: Nagaraju Goruganti <ngorugan@in.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-read-not-sent-by-host-inventory-native.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-read-not-sent-by-host-inventory-native.bb
new file mode 100644
index 0000000..029e6a3
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-read-not-sent-by-host-inventory-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "The inventory map of frus not sent by host for phosphor-ipmi-host"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-host
+
+SRC_URI += "file://fru-config-not-sent-by-host.yaml"
+
+S = "${WORKDIR}"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-read-not-sent-by-host-inventory"
+
+do_install_append() {
+    DEST=${D}${config_datadir}
+    install -d ${DEST}
+    install fru-config-not-sent-by-host.yaml ${DEST}/fru-config-not-sent-by-host.yaml
+}
+