Use variables for MRW XML filename and path

Create an mrw-xml bbclass that has variables for the
MRW XML filename and path to it.  Then, changes all users
of the MRW XML to inherit that class and use those variables.

The filename will default to ${MACHINE}.xml if it hasn't already
been set to something else, such as in a .conf file.

This is done so that the file can be something other than
${MACHINE}.xml.

Change-Id: Ia7021e5a5d5e7946829e58688250aa64250cb00e
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-phosphor/classes/mrw-xml.bbclass b/meta-phosphor/classes/mrw-xml.bbclass
new file mode 100644
index 0000000..5a9c773
--- /dev/null
+++ b/meta-phosphor/classes/mrw-xml.bbclass
@@ -0,0 +1,2 @@
+MRW_XML ??= "${MACHINE}.xml"
+mrw_datadir = "${datadir}/obmc-mrw"