Use variables for MRW XML filename and path

Create an mrw-xml bbclass that has variables for the
MRW XML filename and path to it.  Then, changes all users
of the MRW XML to inherit that class and use those variables.

The filename will default to ${MACHINE}.xml if it hasn't already
been set to something else, such as in a .conf file.

This is done so that the file can be something other than
${MACHINE}.xml.

Change-Id: Ia7021e5a5d5e7946829e58688250aa64250cb00e
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb b/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb
index 12a9b9e..db9cbd9 100644
--- a/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb
+++ b/meta-phosphor/common/recipes-phosphor/mrw/mrw-native.bb
@@ -7,13 +7,14 @@
 inherit obmc-phosphor-license
 inherit obmc-xmlpatch
 inherit native
+inherit mrw-xml
 
 PHOSPHOR_MRW_URI ?= "http://missing-mrw-uri"
 SRC_URI += "${PHOSPHOR_MRW_URI}"
 SRCREV = "${PHOSPHOR_MRW_REV}"
 
 do_install() {
-    install -d ${D}${datadir}/obmc-mrw
-    install -m 0644 ${MACHINE}.xml ${D}${datadir}/obmc-mrw
+    install -d ${D}/${mrw_datadir}
+    install -m 0644 ${MRW_XML} ${D}/${mrw_datadir}
 }