meta-openembedded: subtree update:290ad988fb..b315c1a024

Alex Kiernan (1):
      ostree: Add recipe

Bartosz Golaszewski (3):
      python3-ruamel-yaml: new package
      sshfs-fuse: upgrade 2.10 -> 3.5.2
      python3-dtschema: new package

Hongzhi.Song (1):
      numactl: fix a error about lib32-numactl

Jens Rehsack (1):
      libstatgrab: add recipe for libstatgrab-0.92

Leon Anavi (1):
      mosquitto: update to 1.6.6

Naveen Saini (1):
      rrdtool: suppress appending of installation to perllocal.pod

Oleksandr Kravchuk (1):
      jasper: update to 2.0.16

Peiran Hong (1):
      nmap: Update to 7.80

Randy MacLeod (1):
      rsyslog: update from 8.1907.0 to 8.1908.0

Vincent Prince (1):
      mongodb: bump to version 4.2.0+git18ce5c9

Yi Zhao (1):
      phpmyadmin: upgrade 4.9.0.1 -> 4.9.1

Zang Ruochen (5):
      python-alembic: upgrade 1.1.0 -> 1.2.0
      python-msgpack: upgrade 0.6.1 -> 0.6.2
      python-pysocks: upgrade 1.7.0 -> 1.7.1
      python-pytest: upgrade 5.1.2 -> 5.1.3
      python-urllib3: upgrade 1.25.3 -> 1.25.5

Change-Id: I247e7d6f6ce9fcba0f345e9f9e72cf9a52f98340
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-extended/libstatgrab/libstatgrab_0.92.bb b/meta-openembedded/meta-oe/recipes-extended/libstatgrab/libstatgrab_0.92.bb
new file mode 100644
index 0000000..4ede3c8
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-extended/libstatgrab/libstatgrab_0.92.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Utilities to collect and visualise system statistics"
+HOMEPAGE = "http://www.i-scream.org/libstatgrab/"
+
+LICENSE = "GPL-2.0+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "ncurses"
+
+PACKAGES_prepend = "statgrab statgrab-dbg saidar saidar-dbg ${PN}-mrtg "
+
+# don't use the git tag unless docbooc2x is available to build the manpages
+SRC_URI = "https://github.com/libstatgrab/libstatgrab/releases/download/LIBSTATGRAB_0_92/libstatgrab-0.92.tar.gz \
+          "
+SRC_URI[md5sum] = "5362b2ddbec54b3901e7d70c22cda249"
+SRC_URI[sha256sum] = "5bf1906aff9ffc3eeacf32567270f4d819055d8386d98b9c8c05519012d5a196"
+
+# Perl5 is for tests only
+EXTRA_OECONF = "--without-perl5 --with-mnttab=/proc/mounts"
+
+inherit autotools pkgconfig
+
+FILES_statgrab = "${bindir}/statgrab"
+FILES_statgrab-dbg = "${bindir}/.debug/statgrab"
+FILES_saidar = "${bindir}/saidar"
+FILES_saidar-dbg = "${bindir}/.debug/saidar"
+FILES_${PN}-mrtg = "${bindir}/statgrab-make-mrtg-config ${bindir}/statgrab-make-mrtg-index"
+RDEPENDS_${PN}-mrtg_append = "perl statgrab"