Webui-vue builds with IBM environment variables

To build webui-vue with IBM theme, need to set IBM environment variable
during the webui-vue build.

Yocto has many layers of abstraction. To specify IBM environment
variables, we use --mode npm build Commandline argument, which helps to
set IBM environment variables.

We need to set this environment variable during IBM build only. So
created webui-vue_%.bbappend file, which sets that env variable only
for IBM builds.

More information could be found at
https://github.com/openbmc/webui-vue/blob/master/docs/customization/build.md

Tested with IBM build.

Signed-off-by: Abhishek Patel <Abhishek.Patel@ibm.com>
Change-Id: I6ff997a94eb59b695741ccca95acb7693a4714ff
diff --git a/meta-ibm/recipes-phosphor/webui/webui-vue_%.bbappend b/meta-ibm/recipes-phosphor/webui/webui-vue_%.bbappend
new file mode 100644
index 0000000..fe11d70
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/webui/webui-vue_%.bbappend
@@ -0,0 +1,4 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
+
+EXTRA_OENPM:witherspoon-tacoma = "-- --mode ibm"
+EXTRA_OENPM:p10bmc = "-- --mode ibm"