wspoon: Start hwmon differently for the MAX31785

Add a new udev rule to start the phosphor-hwmon instance for
the MAX31785 fan controller differently than other hwmon devices.

Also introduce different hwmon config files for air and water cooled
systems where the water cooled system doesn't use fan 1.

The new udev rule starts a service that will check the cooling type
and then link in the appropriate config file before starting the
actual phosphor-hwmon service.

Note that this phosphor-hwmon service is still stopped the same as
any other phosphor-hwmon service.

Tested:  Test that phosphor-hwmon is started using the correct
         config files on air and water cooled systems.

Change-Id: Ia93d97df024e7b6bff5eb379ddea4730fe34b55b
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
index 7a83bf0..584418c 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
@@ -1,13 +1,16 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
 SRC_URI += " \
+           file://70-hwmon.rules \
+           file://70-max31785-hwmon.rules \
            file://start_max31785_hwmon.sh \
            "
 
 WSPOON_CHIPS = " \
                i2c@1e78a000/i2c-bus@100/bmp280@77 \
                i2c@1e78a000/i2c-bus@100/dps310@76 \
-               i2c@1e78a000/i2c-bus@100/max31785@52 \
+               i2c@1e78a000/i2c-bus@100/max31785@52_air \
+               i2c@1e78a000/i2c-bus@100/max31785@52_water \
                i2c@1e78a000/i2c-bus@100/power-supply@68 \
                i2c@1e78a000/i2c-bus@100/power-supply@69 \
                i2c@1e78a000/i2c-bus@140/ir35221@70 \
@@ -36,6 +39,9 @@
 SYSTEMD_SERVICE_${PN} += "max31785-hwmon-helper@.service"
 
 do_install_append() {
+    install -d ${D}/${base_libdir}/udev/rules.d/
+    install ${WORKDIR}/70-max31785-hwmon.rules ${D}/${base_libdir}/udev/rules.d/
+
     install -d ${D}${bindir}
     install -m 0755 ${WORKDIR}/start_max31785_hwmon.sh ${D}${bindir}
 }