Remove boost PACKAGECONFIG for class-target

Some BOOST_LIBS such as python and locale are being added by
PACKAGECONFIG. Since we want to limit to the small set of BOOST_LIBS by
default, we can remove anything added by PACKAGECONFIG for class-target.

We found that boost-python is meeting the openssl dependency in the
background, so we also have to add an explicit openssl dependency to
build some applications without boost-python.

This also updates the existing BOOST_LIBS change to only affect
class-target.

Change-Id: I6cd64354ac65ba60b0672a67b9d9e3a7dbe34b01
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
index 203a64b..3922260 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
@@ -36,6 +36,7 @@
 
 
 DEPENDS += "nlohmann-json"
+DEPENDS += "openssl"
 DEPENDS += "phosphor-state-manager"
 DEPENDS += "${@ipmi_whitelists(d)}"
 DEPENDS += "phosphor-dbus-interfaces"