Remove boost PACKAGECONFIG for class-target

Some BOOST_LIBS such as python and locale are being added by
PACKAGECONFIG. Since we want to limit to the small set of BOOST_LIBS by
default, we can remove anything added by PACKAGECONFIG for class-target.

We found that boost-python is meeting the openssl dependency in the
background, so we also have to add an explicit openssl dependency to
build some applications without boost-python.

This also updates the existing BOOST_LIBS change to only affect
class-target.

Change-Id: I6cd64354ac65ba60b0672a67b9d9e3a7dbe34b01
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
diff --git a/meta-phosphor/recipes-support/boost/boost_%.bbappend b/meta-phosphor/recipes-support/boost/boost_%.bbappend
index 7aaa35c..475c830 100644
--- a/meta-phosphor/recipes-support/boost/boost_%.bbappend
+++ b/meta-phosphor/recipes-support/boost/boost_%.bbappend
@@ -8,5 +8,6 @@
 #
 #https://github.com/openbmc/docs/blob/master/cpp-style-and-conventions.md#boost
 #
-BOOST_LIBS:openbmc-phosphor = "chrono thread context coroutine"
+BOOST_LIBS:openbmc-phosphor:class-target = "chrono thread context coroutine"
+PACKAGECONFIG:openbmc-phosphor:class-target = ""