soft-off: install pldm soft off service in targets

This officially enables the pldm soft off service on systems which
choose to install the pldm package.

Tested:
- Confirmed that with all "softoff" Topic patches that a Rainier system
  correctly waited for the host to power down before turning off
  chassis power.

(From meta-phosphor rev: 5e124cdc223024621eb79027d89f070e89a67e67)

Change-Id: If5e2d53852d4dbb3a0f8e39a2cdf3ef53f6aa3cf
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
index 82ed69c..1c07ad5 100644
--- a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
+++ b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
@@ -23,3 +23,26 @@
         -Dtests=disabled \
         -Doem-ibm=disabled \
         "
+
+# Install pldmSoftPowerOff.service in correct targets
+pkg_postinst_${PN} () {
+
+    mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires
+    LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
+    TARGET="../pldmSoftPowerOff.service"
+    ln -s $TARGET $LINK
+
+    mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires
+    LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
+    TARGET="../pldmSoftPowerOff.service"
+    ln -s $TARGET $LINK
+}
+
+pkg_prerm_${PN} () {
+
+    LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
+    rm $LINK
+
+    LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
+    rm $LINK
+}