meta-phosphor: fans: enable non-native recipes

There exists a number native class recipes throughout meta-phosphor that
simply provide a data (often YAML) file as input to building another
application.

Having these data file recipes implemented as native class recipes
prevents the use of machine overrides because bitbake (rightfully so)
discards machine qualifiers from native recipes.  Further, data files
aren't really any different than library header files and those are
consumed by recipes as target class recipes that are DEPENDed on.  Do
the same thing for data file recipes.

A number of steps (patches) are required to ensure backward
compatibility while other BSP layers make the transition to target class
recipes.

This patch is the first step in the sequence.  Each native class recipe
is duplicated with (approximately) the following transformation applied:

1 - remove "inherit native"
2 - add "inherit allarch"
3 - Add appropriate files to FILES_${PN}

Also fixed a couple idiosyncrasies like SRC_URI += and LIC_FILES_CHKSUM
that are not required.

Finally, add a temporary layer of indirection around STAGING_DIR_NATIVE
and STAGING_DIR_HOST to the fan metadata until other BSP layers have
fully transitioned to target class config recipes.

(From meta-phosphor rev: 19ee51f5cdce2ff2f076a3ca9263dabc79072ba9)

Change-Id: I9671cc5343ed29a7ccfcee4cc00ebaaa9327e359
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config.bb
new file mode 100644
index 0000000..b82da0a
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan-control-fan-config.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Phosphor fan definition example data"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit allarch
+inherit phosphor-fan
+
+S = "${WORKDIR}"
+PROVIDES += "virtual/phosphor-fan-control-fan-config"
+
+SRC_URI = "file://fans.yaml"
+
+do_install() {
+    install -D fans.yaml ${D}${control_datadir}/fans.yaml
+}
+
+FILES_${PN} += "${control_datadir}/fans.yaml"