meta-bletchley: enable runtime hardware watchdog

Setup hardware watchdog timeout to 30 sec by systemd

TESTED : Built the openbmc image for Facebook Bletchley hardware
Check RuntimeWatchdogUSec configured to 30s successfully
'# systemctl show|grep RuntimeWatchdogUSec'
RuntimeWatchdogUSec=30s

Signed-off-by: Allen.Wang <Allen_Wang@quantatw.com>
Change-Id: I56b724a39ba63041ada4f33aac8447334a637816
diff --git a/meta-facebook/recipes-core/systemd/systemd_%.bbappend b/meta-facebook/recipes-core/systemd/systemd_%.bbappend
new file mode 100644
index 0000000..c069b22
--- /dev/null
+++ b/meta-facebook/recipes-core/systemd/systemd_%.bbappend
@@ -0,0 +1,14 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI:append:bletchley = " \
+  file://40-system.conf \
+  "
+
+FILES:${PN}:append:bletchley = " \
+  ${systemd_unitdir}/system.conf.d/40-system.conf \
+  "
+
+do_install:append:bletchley() {
+    install -d -m 0755 ${D}${systemd_unitdir}/system.conf.d/
+    install -m 0644 ${WORKDIR}/40-system.conf ${D}${systemd_unitdir}/system.conf.d/
+}
\ No newline at end of file