phosphor-host-ipmid: Add option for configuring dynamic sensors

This makes it possible to enable or disable dynamic sensors. By default
this is now disabled as it is a new feature that is not compatible with
static sensor stacks.

Change-Id: I55fea70642cee4d68153c402478483603805c601
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
index 56df13b..5e93764 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
@@ -21,6 +21,9 @@
     whitelists = [ '{}-whitelist-native'.format(x) for x in whitelists ]
     return ' '.join(whitelists)
 
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[dynamic-sensors] = "--enable-dynamic-sensors,--disable-dynamic-sensors"
+
 DEPENDS += "autoconf-archive-native"
 DEPENDS += "nlohmann-json"
 DEPENDS += "phosphor-state-manager"