meta-raspberrypi: subtree update:3a1fec22c0..4b89f63699

Aaron Shaw (1):
      linux-firmware-rpidistro: Added firmware for BCM43456

Khem Raj (3):
      mesa-gl: Enable swrast dri backend for rpi/userland
      userland: Fix weston build with userland graphics
      libglu: Fix build with userland graphics

Tobias Off (1):
      linux-firmware-rpidistro: Missing link to firmware causes wifi not working on raspberrypi zero w

Trevor Woerner (1):
      userland: fix invalid packageconfig

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I06d2fbef19f827ffcbb485c60935b9a8c373e1c4
diff --git a/meta-raspberrypi/recipes-graphics/userland/userland_git.bb b/meta-raspberrypi/recipes-graphics/userland/userland_git.bb
index 32aa4a5..6dfc8a3 100644
--- a/meta-raspberrypi/recipes-graphics/userland/userland_git.bb
+++ b/meta-raspberrypi/recipes-graphics/userland/userland_git.bb
@@ -44,6 +44,7 @@
     file://0021-cmake-Disable-format-overflow-warning-as-error.patch \
     file://0022-all-host_applications-remove-non-existent-projects.patch \
     file://0023-hello_pi-optionally-build-wayland-specific-app.patch \
+    file://0024-userland-Sync-needed-defines-for-weston-build.patch \
 "
 
 SRC_URI_remove_toolchain-clang = "file://0021-cmake-Disable-format-overflow-warning-as-error.patch"
@@ -54,10 +55,8 @@
 
 ASNEEDED = ""
 
-ALLAPPS = "${@bb.utils.contains('PACKAGECONFIG', 'allapps', '-DALL_APPS=true', '', d)}"
 EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DCMAKE_EXE_LINKER_FLAGS='-Wl,--no-as-needed' \
                  -DVMCS_INSTALL_PREFIX=${exec_prefix} \
-                 ${ALLAPPS} \
 "
 
 EXTRA_OECMAKE_append_aarch64 = " -DARM64=ON "
@@ -66,6 +65,7 @@
 PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
 
 PACKAGECONFIG[wayland] = "-DBUILD_WAYLAND=TRUE -DWAYLAND_SCANNER_EXECUTABLE:FILEPATH=${STAGING_BINDIR_NATIVE}/wayland-scanner,,wayland-native wayland"
+PACKAGECONFIG[allapps] = "-DALL_APPS=true,,,"
 
 CFLAGS_append = " -fPIC"