meta-raspberrypi: subtree update:3a1fec22c0..4b89f63699

Aaron Shaw (1):
      linux-firmware-rpidistro: Added firmware for BCM43456

Khem Raj (3):
      mesa-gl: Enable swrast dri backend for rpi/userland
      userland: Fix weston build with userland graphics
      libglu: Fix build with userland graphics

Tobias Off (1):
      linux-firmware-rpidistro: Missing link to firmware causes wifi not working on raspberrypi zero w

Trevor Woerner (1):
      userland: fix invalid packageconfig

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I06d2fbef19f827ffcbb485c60935b9a8c373e1c4
diff --git a/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb b/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
index 99afde8..671dfa2 100644
--- a/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
+++ b/meta-raspberrypi/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
@@ -8,6 +8,7 @@
 # In maintained upstream linux-firmware:
 # * brcmfmac43430-sdio falls under LICENCE.cypress
 # * brcmfmac43455-sdio falls under LICENCE.broadcom_bcm43xx
+# * brcmfmac43456-sdio falls under LICENCE.broadcom_bcm43xx
 #
 # It is likely[^1] that both of these should be under LICENCE.cypress.
 # Further, at this time the text of LICENCE.broadcom_bcm43xx is the same
@@ -35,8 +36,8 @@
 
 SRC_URI = "git://github.com/RPi-Distro/firmware-nonfree"
 
-SRCREV = "98e815735e2c805d65994ccc608f399595b74438"
-PV = "20190114-1+rpt8"
+SRCREV = "b66ab26cebff689d0d3257f56912b9bb03c20567"
+PV = "20190114-1+rpt10"
 
 S = "${WORKDIR}/git"
 
@@ -56,7 +57,7 @@
     # Replace outdated linux-firmware files with updated ones from
     # raspbian firmware-nonfree. Raspbian adds blobs and nvram
     # definitions that are also necessary so copy those too.
-    for fw in brcmfmac43430-sdio brcmfmac43455-sdio ; do
+    for fw in brcmfmac43430-sdio brcmfmac43455-sdio brcmfmac43456-sdio ; do
         install -m 0644 brcm/${fw}.* ${D}${nonarch_base_libdir}/firmware/brcm/
     done
     # add compat links. Fixes errors like
@@ -64,22 +65,27 @@
     ln -s brcmfmac43455-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt
     ln -s brcmfmac43455-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt
     ln -s brcmfmac43430-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43430-sdio.raspberrypi,3-model-b.txt
+    ln -s brcmfmac43430-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43430-sdio.raspberrypi,model-zero-w.txt
 }
 
 PACKAGES = "\
     ${PN}-broadcom-license \
     ${PN}-bcm43430 \
     ${PN}-bcm43455 \
+    ${PN}-bcm43456 \
 "
 
 LICENSE_${PN}-bcm43430 = "Firmware-broadcom_bcm43xx-rpidistro"
 LICENSE_${PN}-bcm43455 = "Firmware-broadcom_bcm43xx-rpidistro"
+LICENSE_${PN}-bcm43456 = "Firmware-broadcom_bcm43xx-rpidistro"
 LICENSE_${PN}-broadcom-license = "Firmware-broadcom_bcm43xx-rpidistro"
 FILES_${PN}-broadcom-license = "${nonarch_base_libdir}/firmware/LICENCE.broadcom_bcm43xx-rpidistro"
 FILES_${PN}-bcm43430 = "${nonarch_base_libdir}/firmware/brcm/brcmfmac43430*"
 FILES_${PN}-bcm43455 = "${nonarch_base_libdir}/firmware/brcm/brcmfmac43455*"
+FILES_${PN}-bcm43456 = "${nonarch_base_libdir}/firmware/brcm/brcmfmac43456*"
 RDEPENDS_${PN}-bcm43430 += "${PN}-broadcom-license"
 RDEPENDS_${PN}-bcm43455 += "${PN}-broadcom-license"
+RDEPENDS_${PN}-bcm43456 += "${PN}-broadcom-license"
 RCONFLICTS_${PN}-bcm43430 = "\
     linux-firmware-bcm43430 \
     linux-firmware-raspbian-bcm43430 \
@@ -96,6 +102,14 @@
     linux-firmware-bcm43455 \
     linux-firmware-raspbian-bcm43455 \
 "
+RCONFLICTS_${PN}-bcm43456 = "\
+    linux-firmware-bcm43456 \
+    linux-firmware-raspbian-bcm43456 \
+"
+RREPLACES_${PN}-bcm43456 = "\
+    linux-firmware-bcm43456 \
+    linux-firmware-raspbian-bcm43456 \
+"
 
 # Firmware files are generally not run on the CPU, so they can be
 # allarch despite being architecture specific