meta-phosphor: prep for new override syntax

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I588025b614416c43aa2d053765ab53bacf890cb5
diff --git a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
index 1598a7e..e6c223e 100644
--- a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
+++ b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
@@ -33,36 +33,36 @@
         ${PN}-user-mgmt-ldap \
         "
 
-SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
-RDEPENDS_${PN}-bmc-state-mgmt = " \
+SUMMARY:${PN}-bmc-state-mgmt = "BMC state management"
+RDEPENDS:${PN}-bmc-state-mgmt = " \
         ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \
         phosphor-state-manager-systemd-target-monitor \
         obmc-targets \
         "
 
-SUMMARY_${PN}-bmcweb = "bmcweb support"
-RDEPENDS_${PN}-bmcweb = " \
+SUMMARY:${PN}-bmcweb = "bmcweb support"
+RDEPENDS:${PN}-bmcweb = " \
         bmcweb \
         phosphor-bmcweb-cert-config \
         "
 
-SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management"
-RDEPENDS_${PN}-chassis-state-mgmt = " \
+SUMMARY:${PN}-chassis-state-mgmt = "Chassis state management"
+RDEPENDS:${PN}-chassis-state-mgmt = " \
         ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
         obmc-phosphor-power \
         "
 
-SUMMARY_${PN}-console = "Serial over LAN support"
-RDEPENDS_${PN}-console = " \
+SUMMARY:${PN}-console = "Serial over LAN support"
+RDEPENDS:${PN}-console = " \
         obmc-console \
         "
 
 # Deprecated - add new packages to an existing packagegroup or create a new one.
-SUMMARY_${PN}-extras = "Extra features"
-RDEPENDS_${PN}-extras = ""
+SUMMARY:${PN}-extras = "Extra features"
+RDEPENDS:${PN}-extras = ""
 
-SUMMARY_${PN}-devtools = "Development tools"
-RDEPENDS_${PN}-devtools = " \
+SUMMARY:${PN}-devtools = "Development tools"
+RDEPENDS:${PN}-devtools = " \
         bash \
         ffdc \
         i2c-tools \
@@ -71,8 +71,8 @@
         rsync \
         "
 
-SUMMARY_${PN}-dbus-monitor = "Support for dbus monitoring"
-RDEPENDS_${PN}-dbus-monitor = " \
+SUMMARY:${PN}-dbus-monitor = "Support for dbus monitoring"
+RDEPENDS:${PN}-dbus-monitor = " \
         phosphor-dbus-monitor \
         "
 
@@ -80,118 +80,118 @@
 # implementing fan control or system fan policy only.
 # Applications that create inventory or sensors should
 # be added those respective package groups instead.
-SUMMARY_${PN}-fan-control = "Fan control"
-RDEPENDS_${PN}-fan-control = " \
+SUMMARY:${PN}-fan-control = "Fan control"
+RDEPENDS:${PN}-fan-control = " \
         ${VIRTUAL-RUNTIME_obmc-fan-control} \
         phosphor-fan-monitor \
         "
 
-SUMMARY_${PN}-fru-ipmi = "Support for EEPROMS with IPMI FRU"
-RDEPENDS_${PN}-fru-ipmi = " \
+SUMMARY:${PN}-fru-ipmi = "Support for EEPROMS with IPMI FRU"
+RDEPENDS:${PN}-fru-ipmi = " \
         fru-device \
         "
 
-SUMMARY_${PN}-health-monitor = "Support for health monitoring"
-RDEPENDS_${PN}-health-monitor = " \
+SUMMARY:${PN}-health-monitor = "Support for health monitoring"
+RDEPENDS:${PN}-health-monitor = " \
         phosphor-health-monitor \
         "
 
-SUMMARY_${PN}-host-state-mgmt = "Host state management"
-RDEPENDS_${PN}-host-state-mgmt = " \
+SUMMARY:${PN}-host-state-mgmt = "Host state management"
+RDEPENDS:${PN}-host-state-mgmt = " \
         ${VIRTUAL-RUNTIME_obmc-host-state-manager} \
         ${VIRTUAL-RUNTIME_obmc-discover-system-state} \
         "
 
-SUMMARY_${PN}-ikvm = "KVM over IP support"
-RDEPENDS_${PN}-ikvm = " \
+SUMMARY:${PN}-ikvm = "KVM over IP support"
+RDEPENDS:${PN}-ikvm = " \
         obmc-ikvm \
         "
 
-SUMMARY_${PN}-inventory = "Inventory applications"
-RDEPENDS_${PN}-inventory = " \
+SUMMARY:${PN}-inventory = "Inventory applications"
+RDEPENDS:${PN}-inventory = " \
         ${VIRTUAL-RUNTIME_obmc-inventory-manager} \
         ${VIRTUAL-RUNTIME_obmc-fan-presence} \
         "
 
-SUMMARY_${PN}-leds = "LED applications"
-RDEPENDS_${PN}-leds = " \
+SUMMARY:${PN}-leds = "LED applications"
+RDEPENDS:${PN}-leds = " \
         ${VIRTUAL-RUNTIME_obmc-leds-manager} \
         ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \
         ${VIRTUAL-RUNTIME_obmc-led-monitor} \
         "
 
-SUMMARY_${PN}-logging = "Logging applications"
-RDEPENDS_${PN}-logging = " \
+SUMMARY:${PN}-logging = "Logging applications"
+RDEPENDS:${PN}-logging = " \
         phosphor-logging \
         "
 
-SUMMARY_${PN}-remote-logging = "Remote logging applications"
-RDEPENDS_${PN}-remote-logging = " \
+SUMMARY:${PN}-remote-logging = "Remote logging applications"
+RDEPENDS:${PN}-remote-logging = " \
         rsyslog \
         phosphor-rsyslog-config \
         "
 
-SUMMARY_${PN}-rng = "Random Number Generator support"
-RDEPENDS_${PN}-rng = " \
+SUMMARY:${PN}-rng = "Random Number Generator support"
+RDEPENDS:${PN}-rng = " \
         rng-tools \
         "
 
-SUMMARY_${PN}-sensors = "Sensor applications"
-RDEPENDS_${PN}-sensors = " \
+SUMMARY:${PN}-sensors = "Sensor applications"
+RDEPENDS:${PN}-sensors = " \
         ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \
         "
 
 ${PN}-software-extras = ""
 
-${PN}-software-extras_df-obmc-ubi-fs = " \
+${PN}-software-extras:df-obmc-ubi-fs = " \
         phosphor-software-manager-updater-ubi \
         "
 
-${PN}-software-extras_df-phosphor-mmc = " \
+${PN}-software-extras:df-phosphor-mmc = " \
         phosphor-software-manager-updater-mmc \
         "
 
-SUMMARY_${PN}-software = "Software applications"
-RDEPENDS_${PN}-software = " \
+SUMMARY:${PN}-software = "Software applications"
+RDEPENDS:${PN}-software = " \
         ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \
         ${VIRTUAL-RUNTIME_obmc-bmc-updater} \
         ${VIRTUAL-RUNTIME_obmc-bmc-version} \
         ${${PN}-software-extras} \
         "
 
-SUMMARY_${PN}-debug-collector = "BMC debug collector"
-RDEPENDS_${PN}-debug-collector = " \
+SUMMARY:${PN}-debug-collector = "BMC debug collector"
+RDEPENDS:${PN}-debug-collector = " \
         ${VIRTUAL-RUNTIME_obmc-dump-manager} \
         ${VIRTUAL-RUNTIME_obmc-dump-monitor} \
         phosphor-debug-collector-dreport \
         phosphor-debug-collector-scripts \
         "
 
-SUMMARY_${PN}-settings = "Settings applications"
-RDEPENDS_${PN}-settings = " \
+SUMMARY:${PN}-settings = "Settings applications"
+RDEPENDS:${PN}-settings = " \
         phosphor-settings-manager \
         "
 
-SUMMARY_${PN}-network = "BMC Network Manager"
-RDEPENDS_${PN}-network = " \
+SUMMARY:${PN}-network = "BMC Network Manager"
+RDEPENDS:${PN}-network = " \
         ${VIRTUAL-RUNTIME_obmc-network-manager} \
         "
 
-SUMMARY_${PN}-telemetry = "Telemetry solution"
-RDEPENDS_${PN}-telemetry = " \
+SUMMARY:${PN}-telemetry = "Telemetry solution"
+RDEPENDS:${PN}-telemetry = " \
         telemetry \
         "
 
-SUMMARY_${PN}-user-mgmt = "User management applications"
-RDEPENDS_${PN}-user-mgmt = " \
+SUMMARY:${PN}-user-mgmt = "User management applications"
+RDEPENDS:${PN}-user-mgmt = " \
         ${VIRTUAL-RUNTIME_obmc-user-mgmt} \
         "
-RRECOMMENDS_${PN}-user-mgmt = " \
+RRECOMMENDS:${PN}-user-mgmt = " \
         pam-plugin-access \
         "
 
-SUMMARY_${PN}-user-mgmt-ldap = "LDAP users and groups support"
-RDEPENDS_${PN}-user-mgmt-ldap = " \
+SUMMARY:${PN}-user-mgmt-ldap = "LDAP users and groups support"
+RDEPENDS:${PN}-user-mgmt-ldap = " \
         ${PN}-user-mgmt \
         nss-pam-ldapd \
         phosphor-ldap \