PIM: Point PIM at the non-sample dbus interfaces

PIM has a new configure option that needs to be set to the
path of the DBUS interface YAML in the native sysroot.

Update dependency lists.

Change-Id: I20039af00be6876c37c6e02774d24be35c4421bd
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager.bb b/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager.bb
index 1834251..74a9efd 100644
--- a/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager.bb
+++ b/meta-phosphor/common/recipes-phosphor/inventory/phosphor-inventory-manager.bb
@@ -7,6 +7,7 @@
 inherit autotools \
         pkgconfig \
         pythonnative \
+        phosphor-dbus-interfaces \
         phosphor-inventory-manager \
         obmc-phosphor-dbus-service
 
@@ -15,11 +16,17 @@
 DEPENDS += " \
         ${PN}-config-native \
         phosphor-dbus-interfaces \
+        phosphor-dbus-interfaces-native \
+        phosphor-logging \
         sdbusplus \
         sdbusplus-native \
         autoconf-archive-native \
         "
-RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
+RDEPENDS_${PN} += " \
+        sdbusplus \
+        phosphor-dbus-interfaces \
+        phosphor-logging \
+        "
 
 OBMC_INVENTORY_PATH="${OBMC_DBUS_PATH_ROOT}/Inventory"
 OBMC_INVENTORY_MGR_IFACE="${OBMC_DBUS_IFACE_ROOT}.Inventory.Manager"
@@ -33,4 +40,5 @@
         BUSNAME=${OBMC_INVENTORY_MGR_IFACE} \
         INVENTORY_ROOT=${OBMC_INVENTORY_PATH} \
         IFACE=${OBMC_INVENTORY_MGR_IFACE} \
+        IFACES_PATH=${STAGING_DIR_NATIVE}${yaml_dir} \
         "