blob: a4b200a7e84737f26670311dfe7f97e42f94523d [file] [log] [blame]
SUMMARY = "Xfce4 Panel"
SECTION = "x11"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee"
DEPENDS = "libxfce4util garcon libxfce4ui xfconf exo gtk+ gtk+3 dbus cairo virtual/libx11 libxml2 libwnck3 vala-native"
inherit xfce gtk-doc gobject-introspection distro_features_check gtk-icon-cache remove-libtool
REQUIRED_DISTRO_FEATURES = "x11"
SRC_URI[md5sum] = "376e360fb87095edaea7df8ca34fe6a7"
SRC_URI[sha256sum] = "0d05b6dd8c91c154a364a3e31583c5f423c33e26d44d43cc409165f7d578ca15"
SRC_URI += " \
file://0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \
"
python populate_packages_prepend() {
plugin_dir = d.expand('${libdir}/xfce4/panel/plugins/')
plugin_name = d.expand('${PN}-plugin-%s')
do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
'${PN} plugin for %s', extra_depends='', prepend=True,
aux_files_pattern=['${datadir}/xfce4/panel/plugins/%s.desktop',
'${sysconfdir}/xdg/xfce/panel/%s-*',
'${datadir}/icons/hicolor/48x48/apps/*-%s.png',
'${bindir}/*%s*'])
}
PACKAGES_DYNAMIC += "^${PN}-plugin-.*"
PACKAGES =+ "${PN}-gtk3"
FILES_${PN} += "${libdir}/xfce4/panel/migrate \
${libdir}/xfce4/panel/wrapper-1.0"
FILES_${PN}-dev += "${libdir}/xfce4/panel/plugins/*.la"
FILES_${PN}-gtk3 = " \
${libdir}/libxfce4panel-2.0${SOLIBS} \
${libdir}/xfce4/panel/wrapper-2.0 \
"