meta-fii/meta-kudo: Customize chassis power cycle action

Instead of a host or chassis restart for a Chassis PowerCycle,
have both the BMC and host perform a hard reset. This requires
changes to phosphor-state-manager to add the handling of
xyz.openbmc_project.State.Chassis.Transition.PowerCycle. Currently,
there is handling for On and Off, but not PowerCycle.

Signed-off-by: Charles Boyer <Charles.Boyer@fii-usa.com>
Change-Id: I3d934c47a68899b2fd8fcba966f8d92c97554a77
diff --git a/meta-fii/meta-kudo/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-fii/meta-kudo/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index 57e3aa6..bbd60bb 100644
--- a/meta-fii/meta-kudo/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-fii/meta-kudo/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -1,5 +1,7 @@
 FILESEXTRAPATHS:prepend:kudo := "${THISDIR}/${PN}:"
 
+CHASSIS_ACTION_TARGETS:append:kudo = " powercycle"
+
 SRC_URI:append:kudo = " \
     file://xyz.openbmc_project.State.Chassis.service \
     "