meta-facebook: yosemite4: Fix do power policy fail problem

We found out the power policy failed after doing 12v cycle.
Because the 12v power on and cycles execute using pldmtool cmd,
we need to wait until the mctp connection is done, so it can send
cmd to BIC normally.


Signed-off-by: Delphine CC Chiu <Delphine_CC_Chiu@wiwynn.com>
Change-Id: I519340e786a5eaf4dcb27d0eff149c137658434d
diff --git a/meta-facebook/meta-yosemite4/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-facebook/meta-yosemite4/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index e231984..a699610 100644
--- a/meta-facebook/meta-yosemite4/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-facebook/meta-yosemite4/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -34,6 +34,7 @@
     file://host-powercycle \
     file://host-powerreset \
     file://power-cmd \
+    file://wait-until-mctp-connection-done \
     "
 
 RDEPENDS:${PN}:append:yosemite4 = " bash"
@@ -51,6 +52,7 @@
     install -m 0777 ${WORKDIR}/host-powercycle ${D}${libexecdir}/${PN}/
     install -m 0777 ${WORKDIR}/host-powerreset ${D}${libexecdir}/${PN}/
     install -m 0777 ${WORKDIR}/power-cmd ${D}${libexecdir}/${PN}/
+    install -m 0777 ${WORKDIR}/wait-until-mctp-connection-done ${D}${libexecdir}/${PN}/
 }
 
 FILES:${PN} += " ${systemd_system_unitdir}/*.service"