blob: 24a1245fc07284373ba790d250a4219978faba9b [file] [log] [blame]
SUMMARY = "The Perl Database Interface"
DESCRIPTION = "DBI is a database access Application Programming Interface \
(API) for the Perl Language. The DBI API Specification defines a set \
of functions, variables and conventions that provide a consistent \
database interface independent of the actual database being used. \
"
HOMEPAGE = "http://search.cpan.org/dist/DBI/"
SECTION = "libs"
LICENSE = "Artistic-1.0 | GPL-1.0+"
RDEPENDS_${PN} = " perl-module-carp \
perl-module-exporter \
perl-module-exporter-heavy \
perl-module-dynaloader \
"
LIC_FILES_CHKSUM = "file://LICENSE;md5=10982c7148e0a012c0fd80534522f5c5"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz"
SRC_URI[md5sum] = "e77fd37fcf77fc88fde029c1b75ded54"
SRC_URI[sha256sum] = "5509e532cdd0e3d91eda550578deaac29e2f008a12b64576e8c261bb92e8c2c1"
S = "${WORKDIR}/DBI-${PV}"
inherit cpan ptest-perl
do_install_prepend() {
# test requires "-T" (taint) command line option
rm -rf ${B}/t/pod-coverage.t
rm -rf ${B}/t/13taint.t
# source of test failure not obvious
rm -rf ${B}/t/85gofer.t
# unclear why there are several duplicates of tests in tarball
rm -rf ${B}/t/z*.t
}
BBCLASSEXTEND = "native"