blob: b904d935317cedb1e40c4465e7343621dad0c745 [file] [log] [blame]
SUMMARY = "Text shaping library"
DESCRIPTION = "HarfBuzz is an OpenType text shaping engine."
HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz"
BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz"
SECTION = "libs"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=e021dd6dda6ff1e6b1044002fc662b9b \
file://src/hb-ucdn/COPYING;md5=994ba0f1295f15b4bda4999a5bbeddef \
"
DEPENDS = "glib-2.0 cairo fontconfig freetype"
SRC_URI = "http://www.freedesktop.org/software/harfbuzz/release/${BP}.tar.bz2"
SRC_URI[md5sum] = "81dbce82d6471ec2b2a627ce02d03e5d"
SRC_URI[sha256sum] = "a8e5c86e4d99e1cc9865ec1b8e9b05b98e413c2a885cd11f8e9bb9502dd3e3a9"
inherit autotools pkgconfig lib_package gtk-doc
PACKAGECONFIG ??= "icu"
PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu"
EXTRA_OECONF = " \
--with-cairo \
--with-fontconfig \
--with-freetype \
--with-glib \
--without-graphite2 \
"
do_configure_prepend() {
# This is ancient and can get used instead of the patched one we ship,
# so delete it. In 1.8.9 this should be removed upstream.
rm -f ${S}/m4/pkg.m4
}
PACKAGES =+ "${PN}-icu ${PN}-icu-dev"
LEAD_SONAME = "libharfbuzz.so"
FILES_${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"
FILES_${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \
${libdir}/libharfbuzz-icu.so \
${libdir}/pkgconfig/harfbuzz-icu.pc \
"
BBCLASSEXTEND = "native"