ipmitool: Allow devtool modify

The folder doesn't exist during the devtool build so
build fails. Make the folder so build can pass.

Tested: devtool build passes

(From meta-phosphor rev: 7f3994d8fe5ee62ff4b66280a4ef67598b19cbeb)

Change-Id: I41aa578aec3abbd3c87ad7c58f59848fcf6232e8
Signed-off-by: James Feist <james.feist@linux.intel.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend b/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
index 8f390f5..a6a8198 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
+++ b/meta-phosphor/recipes-phosphor/ipmi/ipmitool_%.bbappend
@@ -23,6 +23,7 @@
 do_compile_prepend() {
     # copy the SRC_URI version of enterprise-numbers
     # to the build dir to prevent a fetch
+    mkdir -p "${WORKDIR}/build"
     cp "${WORKDIR}/enterprise-numbers" "${WORKDIR}/build/enterprise-numbers"
 }