blob: 2dd6d38828aec4d2af581496d8867e0244912cd3 [file] [log] [blame]
SUMMARY = "Program for creating simple man pages"
SECTION = "devel"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
DEPENDS = "autoconf-native automake-native"
SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz"
SRC_URI[md5sum] = "1c886063c9e0ab463906de804596aa2f"
SRC_URI[sha256sum] = "7ca60b2519fdbe97f463fe2df66a6188d18b514bfd44127d985f0234ee2461b1"
inherit autotools native
EXTRA_OECONF = "--disable-nls"
# We don't want to reconfigure things as it would require 'perlnative' to be
# used.
do_configure() {
oe_runconf
}
do_install_append () {
# Make sure we use /usr/bin/env perl
sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
}